Pip install matplotlib mac fails

OP is using Lion. Sign up or log in Sign up using Google. Sign up using Facebook.

Your Answer

Sign up using Email and Password. Post as a guest Name.


  • Related Articles.
  • .
  • cashflow 101 mac os x!
  • PIP Install on Mac: Operation Not Permitted.
  • sims 3 no mods folder mac.
  • building project management software mac.
  • .

Email Required, but never shown. Post Your Answer Discard By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service , privacy policy and cookie policy , and that your continued use of the website is subject to these policies.

Already on GitHub? Sign in to your account. I have the same error with pip, but when I clone from the git repo, I get a different libpng related error: Same setup as diimdeep, osx The error you're getting with pip was a bug that was fixed and merged.

Don't Leave Home Without Them

Where does your install of libpng live? I created a homebrew formula to install libpng12 and link matplotlib with that, and this worked. I have libpng14 installed via macports and matplotlib compiled successfully from that. Has anybody else had problems getting matplotlib to install with libpng15? I did notice that git clone installs matplotlib version 1.


  • download flash plugin safari mac.
  • free microsoft word for mac product key.
  • .
  • java nao funciona no chrome mac.
  • makeup forever powder foundation vs mac studio fix.

This has been fixed, see When 1. There is however a formula on github that provides it. Does not help, though. The following worked for me: How does one install pkg-info? Actually, I think it should be pkg-config , so brew install pkg-config. And don't forget to brew link it too.

I had pkg-config installed, but it didn't work.

Make sure the freetype2. David Xia David Xia 3 As of today, Matplotlib should be at version 1. I actually wrote something about this here.

Maybe you can find some useful information in there. Sorry, that's a typo.


  • logiciel de montage video pro pour mac.
  • python - Error in pip install matplotlib in Mac - Stack Overflow.
  • adobe cc cleaner tool for mac.

I meant 1. With MacPorts this would be sudo port install pymatplotlib which resolves the dependencies automatically. Tim Tim 1, 2 13 I personally prefer Homebrew to MacPorts or Fink since it relies on system libs and is way more hackable. If you don't care about that, using MacPorts or Fink is probably the easiest solution.

Installation — Matplotlib documentation

The answer is, there's no freetype library. Zhengyang Liu Zhengyang Liu 7. No available formula for freetype. Did the name change? Same problem using macports.



admin